FXCoral

Playstation Network doesn't want to "dance" with Brave browser

I'm a big fan of Brave browser and have never had any issues with it until now. I love how they block most content that a vast majority of us find annoying such as pop ups and your personal information / browsing history being shared etc. I am quite certain they are using this information in other ways because after all, they are a company and companies need to make money.

This is the first real problem that I have ever had with .

Like most people with a PS4 / PS Whatever, I rarely intentionally sign into my account. Those details are stored automatically by my PS4 and it does it on its own when it needs to. However, the other day due to the fact that I was playing something that has connectability that looked like it would be fun if i linked with my computer, I decided to connect manually through my computer.

When i went through the usual process I was eventually greeted by this:

ps4loginerror.png

Since I live in a building with shared internet I thought ok, maybe it is just one of those days where the world is trying to piss me off or maybe the sharks are attacking the underwater cables again (a cable that I don't really believe exists and they use as an excuse anytime something doesn't work) but literally everything else on the internet was working. Even stupid shit that I rarely use wasn't having any problems at all. I also tried accessing the account via a tablet that I rarely use for anything and a also another laptop that I run Linux Mint on - all of these use some variant of the Brave browser by default.

I hate error codes like the ones above because even if you are fortunate enough to get to talk to a real human being with tech support in a company like Sony, good luck relaying that absurd code jargon to them over the phone especially when they are using some dodgy VOIP service and keep interrupting you when they are trying to tell them that long as hell code.

So after exhausting all of my options (and also not ever speaking to a human after being on hold for 20 minutes and hanging up) I came up with a brilliant idea of attempting to log in using a different browser. I started with Chrome and it worked without a hitch, just for experimentation purposes I tried with Firefox - a browser I used to love but feel as though they have fcked it up over the years. I even used the dreaded MS Edge browser and all of them were able to login.

Untitled.png

Now I am not going to sit here and try to pretend that I have any idea how it is that this has happened, but it did happen and it is the first problem I have ever had with Brave. This is very disappointing to me because thus far, I have felt that it is the best browser on the market by far.

So Brave, this is the first thumbs down moment you get from me after I dunno, a year or so of use. I don't know what is going on here and it could actually be Sony's fault because they do tend to engage in somewhat nefarious activities with our personal information with their partners as well.

I will still continue to use Brave because it is the only browser that I have that has never "Stopped responding" out of all the ones I have ever used. However, this is a bit concerning to me.

Have any of you out there in internet land ever had any issues similar to this one while using Brave? I'd love to hear about it in the comments if you have!

Technology

Future reading